Составить программу, проверяющую, является последовательность из к целых чисел, вводимых с клавиатуры, возрастающей. c++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Mon45
28.02.2020 15:20
Program z1; var s, s1, s2, s3, s4, s5, s6, s7, s8:string; begin s:='программа'; s1:=copy (s, 4, 4); s4:=copy (s, 2, 3); s5:=copy (s, 2, 1); s2:=s4+s5; s6:=copy (s, 4, 1); s7:=copy (s, 3, 1); s8:=copy (s, 5, 2); s3:=s6+s7+s8; writeln (s1, s2, s3); end. Посмотри, это пункт а. Если то, что нужно, сделаю остальные.. Program z1; var s, s1, s2, s3, st, o, l, be, c: string; begin s1:='страх'; s2:='белка'; s3:='цыпленок'; st:=copy (s1, 1, 2); o:=copy (s3, 7, 1); l:=copy (s2, 3, 1); be:=copy (s2, 1, 2); c:=copy (s3, 1, 1); s:=st+o+l+be+c; writeln (s); end.
0,0(0 оценок)
Ответ:
gea99
08.10.2022 11:52
255 в двоичной системе сч = 11111111, т.е при умножении на него поразрядно сохраняется то число, которое умножаем на 255.
Это значит, что первые две тройки чисел останутся прежними  130.132.
Последнее число в маске это 0. В двоичной с.с 00000000. При умножении на 0 будет ноль. Это значит, что последняя цифра 0.
Т.е. получим  130.132.      .0
Остается выяснить середину.
131 - 10000011
192 - 11000000
Тогда поразрядное умножение нам дает
10000000, При переводе в десятичную с.с 2^7=128
Получили новый адрес
130.132.128.0
Сопоставим с буквами
EBAF
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота