ggggbbb90
18.12.2020 01:41

Решить паскаль у вас есть доллары. вы хотите обменять их на рубли. информация о курсе доллара в банках города хранится в массиве. в городе n банков. составить программу, определяющую, какой банк выбрать, чтобы выгодно обменять доллары на рубли. 2. дан массив. найти значение минимальный элемент
среди элементов, стоящих на четных местах.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yakymov
17.01.2022 04:30
Const n=4; m=5;
var a:array [1..n,1..m] of integer;
 i,j,min,imin,jmin:integer;
begin
Randomize;
Writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do begin
 a[i,j]:=random(21)-10;
 write(a[i,j]:6);
 end;
writeln;
end;
min:=a[1,1]; imin:=1;jmin:=1;
for i:=1 to n do
 for j:=1 to m do
  if a[i,j]<min then
   begin min:=a[i,j]; imin:=i; jmin:=j; end;
writeln('min=a[',imin,',',jmin,']=',min);
end.

Пример:
Исходный массив:
     5     8     2    -5    -4
     1   -10     9     1    -4
     8     2    -6    -4    -4
     8     7     3     2     2
min=a[2,2]=-10
0,0(0 оценок)
Ответ:
AlbertoRey
24.02.2020 22:39
Если элементы массива идут по возрастанию, то вот так

program wstawka;
uses crt;
const min=1;
max=20;
type zona=min..max;
massiw=array[zona] of integer;
var mas:massiw;
i,j:zona;
a,N,M:integer;
T:boolean;
BEGIN randomize;
clrscr; N:=random(20);
writeln('4ucJlo N = ',N);
 M:=random(20); Writeln('4ucJlo M = ',M);
for i:=min to max-2 do
begin
mas[i+1]:=mas[i]+random(5);
write(mas[i],' ');
end;
for i:=min to max-2 do
if (mas[i]>N) and (t=false) then
begin
t:=true;
a:=mas[i];
mas[i]:=N;
for j:=i+1 to max do
begin
N:=mas[j];
mas[j]:=a;
a:=N;
end;
end;
for i:=min to max-1 do
if (mas[i]>M) and (t=true) then
begin
t:=false;
a:=mas[i];
mas[i]:=M;
for j:=i+1 to max do
begin
M:=mas[j];
mas[j]:=a;
a:=M;
end;
end;
writeln;
for i:=min to max do
write(mas[i],' ');
readkey;
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота