AlexanderVard
09.12.2021 08:59

70 напишите программу для решения : торт весом т кг режут на порции. каждая порция торта весит р грамм. сколько гостей можно угостить тортом? программа должна запрашивать ввод необходимых данных и выводить ответ, который должен являться решением . через программу питон 3.5.2 пришлите файл

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vika8086
27.03.2022 22:36

1.

var s: string;

begin

write('Введите слово: ');

readln(s);

while (s<>'хватит') do

 begin

 writeln(s+'!');

 write('Введите слово: ');

 readln(s);

 end;

writeln('До следующих встреч');

end.

2.

var i,n,max,min: integer;

begin

randomize();

n:=random(201)-100;

max:=n;

min:=n;

write(n,' ');

For i:= 2 to 20 do

 begin

 n:=random(201)-100;

 write(n,' ');

 if (n>max) then max:=n;

 if (n<min) then min:=n;

 end;

writeln('Наибольшее число: ',max);

writeln('Наименьшее  число: ',min);

end.

0,0(0 оценок)
Ответ:
лольтоаш
23.03.2023 12:10

l1=input('Введите элементы массива через пробел ').split()

l2=[]

for i in range(len(l1)):l2.append(l1[i])

c=0

for i in range(len(l1)):

   if str(l1[i]).count('1')==0 and str(l1[i]).count('3')==0 and str(l1[i]).count('5')==0 and str(l1[i]).count('7')==0 and str(l1[i]).count('9')==0:

       l1[i]=max(l1)

       c+=1

print('Старый массив: ')

for i in range(len(l2)):print(l2[i],end=' ')

print('\nНовый массив: ')

for i in range(len(l1)):print(l1[i],end=' ')

print('\nКоличество замен: ')

if c !=0:print(c)

else:print('замен не было')

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота