HICKOinc
27.03.2022 03:43

Составьте программу в паскале при умножении на 4 четырехзначного числа, все цифры которого различны, получается число, записываемое теми же цифрами, но в обратном порядке. какое это число?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vanyad09
17.12.2020 01:03
Var       
i, a, b, c: integer;

function check_is(a, b, c: integer):
 boolean;
begin     
 if a >= b + c then check_is := false
else        if b >= a + c then
 check_is := false else     
  if c >= a + b then check_is := false else     
         check_is := true;           
       end;
procedure check_how(a, b, c: integer);begin 
     if ((a = b) and (b = c) and (a = c)) then writeln('равносторонний') else   
    if ((a = b) or (b = c) or (a = c)) then writeln('равнобедренный') else              writeln('разносторонний');     
  end;

begin     
 writeln('Введите стороны треугольника');   
    read(a, b, c);   
    if check_is(a, b, c) then check_how(a, b, c) else writeln('Нет такого треугольника!');          
   end.
0,0(0 оценок)
Ответ:
настя7566
17.12.2020 01:03

var a,b,c,z:integer;

begin

readln(a, b, c);

z:=0;

if (a > b) and (a > c) then begin

   z:= b+c;

   if a >= z then

       writeln('Это не треугольник')

   else write('Это разностороний треугольник');

end

else if (b > a) and (b > c) then begin

   z:= a+c;

   if a >= z then

       writeln('Это не треугольник')

   else write('Это разностороний треугольник');

end

else if (c > a) and (c > b) then begin

   z:= b+a;

   if a >= z then

       writeln('Это не треугольник')

   else write('Это разностороний треугольник')

end

else if (a = b) and (a = c) then

   write('Это равностороний треугольник')

else write('Это равнобедренный треугольник');

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота