Составить программу на паскале: заполнить массив вм случайными числами из диапазона от 1 до 150. размерность массива 20.распечатать массив на экране в строку. найти сумму всех нечётных чисел массива. результат вывести на экран в отдельной строке.
program n_1; const n = 20; var a: array [1..n] of integer; i, sum: integer; begin sum := 0; for i := 1 to n do begin a[i] := random(150) + 1; write('a[', i, '] = ', a[i], '; '); if odd(a[i]) then inc(sum, a[i]); end; writeln (); write('sum = ', sum); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку