elyp28
07.10.2021 04:49

Напишите программу которая будет искать в массиве два числа и считать их произведения

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KiryaRossokha
09.10.2020 21:19

var  

a: array[1..100] of integer;  

n, i: byte;  

sum, p: integer;

begin  

Randomize;  

readln(n);  

sum:=0; p:=1;  

for i:=1 to n do    

begin      

a[i]:=Random(101)-50;      

write(a[i]:4);      

sum:=sum+a[i];      

p:=p*a[i];    

end;  

writeln;  

writeln('Сумма = ', sum:5);  

writeln('Произведение = ', p:5);  

sum:=0; p:=1;  

writeln('');  

writeln('2. С клавиатуры');  

for i:=1 to n do    

begin    

write('Элемент ', i, ' = ');    

readln(a[i]);    

sum:=sum+a[i];    

p:=p*a[i];    

end;  

writeln('Сумма = ', sum:5);  

writeln('Произведение = ', p:5);

end.


Подробнее - на -

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота