albinashav
16.08.2021 18:17

Составить программу используя неполный оператор ветвления для выводы на экран фигуру по углу , в инфе не шарю.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Bomb9931
15.08.2021 21:21

#include <iostream>

using namespace std;


int a, b, numb;

bool init;


int main()

{

do {

 cout << "Input a b: ";

 cin >> a >> b;

 if ((a > b) || (a <= 0) || (b <= 0))

  cout << "Input error! Try again" << endl;

} while ((a > b) || (a <= 0) || (b <= 0));

 

for (int i = a; i <= b; i++) {

 init = true;

 numb = i;

 do {

  if (numb % 10 == 0)  

   init = false;

  else if ((i / (numb % 10) * (numb % 10)) != i)

   init = false;

  numb /= 10;

 } while (numb != 0);

 if (init == true)  

  cout << i << " ";

}

return 0;

}

0,0(0 оценок)
Ответ:
maksdvinskih
15.08.2021 21:21
Можно конечно поизвращаться и придумать интересный алгоритм, но можно просто написать в лоб цикл с проверкой.

#include <iostream>
int main(){
    int num_1, num_2;
    cin >> num_1 >> num_2;
    for (int i = num_1 + 1; i != num_2; i++) {
        int cur = i, num = i;
        int res = 0;
        while (cur != 0) {
            int mod_n = cur % 10;
            if (mod_n == 0) {
                break;
            }
            if (num % mod_n == 0) {
                res = 1;
            }
            else {
                res = 0;
                break;
            }
            cur /= 10;
        }
        if (res) {
            cout << i << ' ';
        }
    }
}

Коротко, в двух словах, о чем тут код. 
мы проходим по циклу от A до B, для каждого числа, в цикле проверяем, делится ли оно на цифры из которых состоит. Для этого мы запоминаем в отдельную переменную cur наше число, и проверяем остаток от деления на 10 (т.е. самую левую цифру), после мы в cur записываем тоже число, но без последней цифры.
на примере 124. проверяем на делимость на 4, потом запоминаем 12, проверяем на делимость на 2, потом запоминаем 1, проверяем на делимость на 1, потом записываем 0. Как только видим 0 прекращаем. 
Дальше в цикле есть проверка на то, что если хоть раз что-то не поделилось, то переходим к след. числу
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота