ивт сделать 1 задания . Составьте программу, выводящую на экран квадраты чисел в строку от 10 до 20 включительно, используя цикл с параметром. Результат программы: 100, 121, 144, 169, 196, 225, 256, 289, 324, 361, 400
uses Crt; const nn=1000; var i,n,mn:integer; a:array[1..nn] of integer; begin Randomize; ClrScr; Write('n='); Read(n); mn:=1000; for i:=1 to n do begin a[i]:=Random(199)-99; Write(a[i],' '); if a[i]<mn then mn:=a[i] end; Writeln; Writeln('Наим. элемент ',mn); ReadKey end.
uses Crt; var i,n,mn:integer; a:array of integer; begin Randomize; ClrScr; Write('n='); Read(n); SetLength(a,n); mn:=1000; for i:=0 to n-1 do begin a[i]:=Random(199)-99; Write(a[i],' '); if a[i]<mn then mn:=a[i] end; Writeln; Writeln('Наим. элемент ',mn); ReadKey end.
Выполнение приведено во вложении 2
// 3. PascalABC.NET 3.2, 2016г., современное решение
begin var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println; Writeln('Наим. элемент ',a.Min) end.
Выполнение приведено во вложении 3.
Сделать выводы каждый может сам...
Примечание: все решения сделаны в среде PascalABC.NET 3.2, который для уровня школьных задач можно считать совместимым на уровне исходного текста с вышеприведенными версиями паскалей.
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017 // Внимание! Если программа не работает, обновите версию!
begin Writeln('*** Исходный массив ***'); var a:=MatrRandom(5,5,-99,99); a.Println(4); var min5:=a.Row(4).Min; for var i:=0 to 4 do for var j:=0 to 4 do if a[i,j].IsOdd then a[i,j]:=min5; Writeln('*** Результирующий массив ***'); a.Println(4) end.