stozhok1998
26.08.2020 01:28

Составить программу вычисления, w=b+(a-b): (c+1) a сумма положительный элементов массива b количество отрицательных элементов массива c произведение элементов массива с нечетными номерами полученные значения элементов a,b,c,w вывести на печать.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
NASTUHA6
09.10.2020 20:11

const N=1000;

var K: array [1..N] of integer;

i,A,B,C: integer;

W: real;

begin

for i:=1 to N do K[i]:=random(101)-50;

A:=0;

B:=0;

C:=1;

for i:=1 to N do begin

if K[i]>0 then A:=A+K[i];

if K[i]<0 then B:=B+1;

if i mod 2<>0 then C:=C*K[i];

end;

W:=B+(A-B)/(C+1);

writeln(W);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота