Егорик69
21.05.2023 08:56

Составьте программу, которая все числа кратные 10 делит на 10 а остальные умножает на 10. ввод элементов массива либо с клавиатуры, либо случайным образом. количество элементов массива задайте самостоятельно. побыстрее

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Даня1221
09.10.2020 15:09

const n=10;

var i:integer;

a:array[1..n] of integer;

begin

for i:=1 to n do

begin

a[i]:=random(100);

write(a[i]:3,' ');

if a[i] mod 10 = 0 then a[i]:=a[i] div 10

else a[i]:=a[i]*10

end;

writeln;

for i:=1 to n do write(a[i]:3,' ')

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота