artemcxt
06.04.2022 06:47

Необходимо решить следующую предметную и написать программу на языке паскаль. для любого целого k обозначим количество цифр в его десятичной записи ц(k). например: ц(1)=1, ц(9)=1, ц(10)=2. дано натуральное число n. вычислить: ( ц(1)/1 ) + ( ц(2)/2^2 ) + +( ц(n)/n^2 )

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
artemka222288
09.10.2020 13:21

program crash;

 

var n, k: integer;

   r: real;

 

begin

 write('n = ');

 readln(n);

 k := 0;

 r := 0;

 while n > 0 do

   begin

     k := k + 1;

     r := r + (n mod 10) / (k * k);

     n := n div 10

   end;

 writeln('r = ', r:0:14);

 readln

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота