tarasov78
31.03.2023 15:03

Составить программу на языке c++ которая будет определять количество точек с целочисленными координатами принадлежащих кругу с радиусом r , с центром в начале координат.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mashagalushko2
09.10.2020 12:40

#include <iostream>


using namespace std;



int main() {


  long long i,j,r,n;


  cout<<"r = ";  cin>>r;


  i=r; j=1; n=0;


  while (i>=1) {


      while (i*i+j*j<=r*r) j=j+1;


      n=n+r-j+1;


      i--;


  }


  n=2*(2*r+1)-1+4*r*r-n*4;


  cout<<n<<endl;


  system("pause");


  return(0);


}



Составить программу на языке c++ которая будет определять количество точек с целочисленными координа
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота