eerihovp08oqz
08.04.2020 07:53

Написать программу на языке с++(без использования std: : string)
с цикла определите является ли сумма цифр введенного натурального числа четной или нечетной. со всеми объяснениями (и напишите какой оператор цикла использовали в коде)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DAMALOVE
29.06.2020 17:52
Class OftenChar{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in);
  String string = in.nextLine(); char chars[] = new char[4];
  chars[0] = in.nextLine().charAt(0); chars[2] = in.nextLine().charAt(0);
  for(int sChar = 0; sChar<string.length(); sChar++)
   if(string.charAt(sChar)==chars[0])chars[1]++;
   else if(string.charAt(sChar)==chars[2])chars[3]++;
  System.out.print("\n"+(chars[1]==chars[3]?chars[0]+""+chars[2]:chars[1]>chars[3]?chars[0]:chars[2]));
 }
}
0,0(0 оценок)
Ответ:
lenin1488
19.04.2022 03:20

#include<iostream>

using namespace std;

signed main() {

setlocale(LC_ALL, "Rus");

int N;

cin >> N;

int* a = new int[N];

for (int i = 0; i < N; i++)

{

 cin >> a[i];

}

//выводим индексы четных элементов

cout << "Номера тех элементов, значения которых чётны: ";

for (int i = 0; i < N; i++) {

 if (a[i] % 2 == 0)

  cout << i << " ";

}

//выводим весь массив

cout << "\nМассив: ";

for (int i = 0; i < N; i++)  

 cout << a[i] << " ";

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота