vikahamka711
03.12.2021 09:26

Напишите программу, которая принимает два вещественных числа, значение для числа десятичных знаков, вычисляет сумму и выводит результат. попробуйте ввести действительное число для числа знаков после запятой.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
svatoslavsasko3
09.10.2020 07:29

program Real2;

var

 a, b, d: Real;

 id: Integer;

begin

 Write ('Введите два вещественных числа: ');

 Read (a, b);

 Write ('Введите число знаков после запятой: ');

 Read (d);

 id := Trunc (d);

 WriteLn;

 Write ('Сумма = ', a + b :15 :id);

 ReadLn;

 ReadLn;

end.

Объяснение:

действительное число для количества знаков после запятой вводится в d, затем чтобы использовать его в форматировании вывода преобразуется в целое (id := Trunc (d); ).

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота