guna3
08.12.2022 22:54

Как в pascalabc ввести строку с количеством символов > 255

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ilyavladimirov1
27.09.2022 09:15
//PascalABC.NET
//Постройте алгоритм и составьте программу, по которой будет реализован
//следующий вариант сценарий: компьютер запрашивает номер дня недели,
//после ввода компьютер сообщает название этого дня (типо если ввели
//1 это понедельник 3 - среда)

type Arr = array [0..6] of string;

begin
    var DN: Arr := ('Воскресенье', 'Понедельник', 'Вторник', 'Среда',
                'Четверг', 'Пятница', 'Суббота');
    write('Введите порядковый номер дня недели: ');
    var n := ReadlnInteger;
    write('Этот день называется ', DN[n mod 7])
end.

Постройте алгоритм и составьте программу, по которой будет реализован следующий вариант сценарий: ко
0,0(0 оценок)
Ответ:
Виктория6789045
22.11.2021 13:38

1) a = 12;

2) a= 16;

3) i = 6;

4) c = 6;

5) a = 22;

6) a = 15;

7) a = 3;

8) 5=Z(3) ;

9) a = 8;

10) a = 14;

11) a = 12;

12) Z(a)=(b) ;

13) i = 3;

Объяснение:

1) Программа не войдет в цикл т.к. i = 3 => значение а не изменится.

2) a = 4;  a + a = 8; a + a = 16

3) Цикл выполнится 4 раза в том случае, если значение i будет на 3 больше, чем в условии, т.к. установлено >= и за цикл из i вычитается 1.

4) a = 20; b = 3; b = 20/3 (без остатка) = 6; с = 20/7 (только остаток) = 6.

5) a = 10; т.к. a<15, то a = a + 12 = 10 + 12 = 22;

6) a = 10; т.к. a > 5, то a = a -7 = 10 - 7 = 3; т.к. a < 5, то a = a + 12 = 3 + 12 = 15.

7) a = 10; т.к. a > 5, то a = a - 7 = 10 - 7 = 3.

8) 5=Z(3)

9) a = 10; a = 10 - 1 = 9; a = 9 - 1 = 8

10) a = 12; т.к. i = 2, что меньше чем 3, то цикл сработает 1 раз (т.к. внутри его i увеличится на 1) => a = a + i = 12 + 2 = 14.

11) a = 10; т.к. a > 5, то a =12. ( не знаю, нужна ли там ; после then, но в любом случае ответ будет такой)

12) Z(a)=(b)

13) Цикл выполнится 2 раза в том случае, если значение i будет на 1 больше, чем в условии, т.к. установлено >= и за цикл из i вычитается 1.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота