Каокогклвтсд223
16.05.2020 04:13

Написать программу, которая использовает оператор while, решение уравнения : y = 1- x + x * x / 2 + 5x, при -5 < x < 6.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lexa3678
02.09.2020 07:25

#include <stdio.h>

#include <stdlib.h>


int main()

{

   // y = 1 - x + x * x / 2 + 5x

   // -5 < x < 6


   // Считываем x:

   float x;

   printf("Enter x: ");

   scanf("%f", &x);


   // Проверяем условие с цикла while:

   // PS: для извращенцев.

   int i = 0;

   while (i == 0)

   {

       if (-5 >= x)

       {

           return EXIT_FAILURE;

       }

       if (x >= 6)

       {

           return EXIT_FAILURE;

       }

       i = 1;

   }


   // Решаем уравнение:

   float y = 1 - x + x * x / 2 + 5 * x;


   // Выводим результат:

   printf("Result y = %f\n", y);

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота