ohcarl
01.11.2022 22:27

35 !
ниже записана программа. получив на вход число , эта программа печатает два числа, и . укажите максимальное и минимальное числа, при вводе которых алгоритм печатает сначала 3, а потом 7.
цел x, l, m
ввод x
l: =0; m: =0
нц пока x > 0
l: = l + 1
если mod(x,2) = 1 то
m: = m + div(mod(x,10),2)
все
x: = div(x,10)
кц
вывод l, нс
вывод m, нс
var x, l, m: integer;
begin
readln(x);
l: =0; m: =0;
while x > 0 do begin
l: = l + 1;
if x mod 2 = 1 then
m: = m +
(x mod 10) div 2;
x: = x div 10;
end;
writeln(l); write(m);
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

Пользователь знает ключ, или

пароль, который известен только ему. К этой группе можно отнести и идентификацию через смс-уведомления. При вводе имени и пароля пользователя сервер сравнивает введенные данные

с сохраненными данными. В случае полной идентичности введенных данных появляется возможность войти в систему.

Различают два вида паролей – динамические

и постоянные. Постоянные пароли изменяются

только по требованию пользователя, а динамические пароли изменяются по определенным параметрам. Например, если пользователь забудет

пароль, сервер может предложить ему динамический пароль для входа в систему.

Объяснение:

0,0(0 оценок)
Ответ:
tana2811
17.12.2022 04:17
Procedure GetAB(x: integer; var a: integer; var b: integer);
begin
    a := 0;
    b := 1;
    while x > 0 do
    begin
        a := a + 1;
        b := b * (x mod 100);
        x := x div 100;
    end;
end;

var
    x, a, b: integer;

begin
    for x := 10000 to 2000000000 do
    begin
        GetAB(x, a, b);
        if (a = 3) and (b = 18) then
            Println(a, b, x);
    end;
end.

выдает такие значения
3 18 10118
3 18 10209
3 18 10306
3 18 10603
3 18 10902
3 18 11801
3 18 20109
3 18 20303
3 18 20901
3 18 30106
3 18 30203
3 18 30302
3 18 30601
3 18 60103
3 18 60301
3 18 90102
3 18 90201
3 18 180101

Выделенное наибольшее
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота