Z0L0Tk0C00L
18.03.2023 12:23

1для заданного числа n составьте программу вычисления суммы s=1+1/2+1/3+1/4+…+1/65. 2 вывести на экран кубы целых чисел от 1 до 9. найти сумму и определить количество полученных чисел. 3 напишите программу вывода всех четных чисел от 2 до 100 включительно и подсчитайте сумму. 4 напишите программу, определяющую сумму всех нечетных чисел от 1 до 99.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alsu7691
08.10.2020 17:17
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  SeqGen(ReadInteger('n='),i->1/(1+i)).Sum.Println; // №1
  // №2
  var a:=ArrGen(9,i->(i+1)*Sqr(i+1)); a.Println;
  Writeln('Кол-во=',a.Length,', S2=',a.Sum);
  Writeln('S3=',Range(2,100,2).Println.Sum); // №3
  Writeln('S4=',Range(1,99,2).Sum) // №4
end.

Пример
n= 65
4.75927551909038
1 8 27 64 125 216 343 512 729
Кол-во=9, S2=2025
2 4 6 8 10 12 14 16 18 20 22 24 26 28 30 32 34 36 38 40 42 44 46 48 50 52 54 56 58 60 62 64 66 68 70 72 74 76 78 80 82 84 86 88 90 92 94 96 98 100
S3=2550
S4=2500
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота