vikapuzya200
27.01.2023 22:53

Составить программу в паскале.расчет значения функции x-2/sqrt(x*x-2*x) при х из отрезка (-10; 10) изменяющимся с шагом 1.должен быть цикл for.заранее

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Aizere1111
21.08.2020 15:19
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  for var x:=-10 to 10 do
    Writeln(x:3,x-2/Sqrt(x*x-2*x):15:10)
end.

Как видно из представленных во вложении результатов, современный Паскаль легко справляется и с отрицательным значением подкоренного выражения (NaN - Not a Number - не число) и с делением на ноль (-infinity - минус бесконечность).

Составить программу в паскале.расчет значения функции x-2/sqrt(x*x-2*x) при х из отрезка (-10; 10) и
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота