Kisyshka
31.08.2022 22:19

Написать программу,находящую скорость или время или пройденное расстояние в зависимости от запроса пользователя.(авс паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alexalex251003
08.10.2020 15:24
Program fgg;

var
x: String[10];
t, v, s: Real;

begin
Write('Что будем искать?: ');
ReadLn(x);
if x = 'скорость' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите время: ');
ReadLn(t);
WriteLn('Скорость=', s / t);
end
else if x = 'время' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите скорость: ');
ReadLn(v);
WriteLn('Время=', s / v);
end
else if x = 'расстояние' then
begin
Write('Введите скорость: ');
ReadLn(v);
Write('Введите время: ');
ReadLn(t);
WriteLn('Расстояние=', v * t);
end
else
WriteLn('Неверно указано, что будем искать.');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота