Rona1234
21.12.2020 06:59

Напишите программу, которая для введенной десятичной дроби выполняет сдвиг десятичной точки на указанное число разрядов (позиций) вправо (если количество разрядов задано положительное) или влево (если количество разрядов задано отрицательное). язык pascal

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
gfgfvfvfuelrjds
08.10.2020 11:42
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadReal('Введите число:');
  var k:=ReadInteger('Введите величину сдвига десятичной точки:');
  a:=a*10**k;
  a.Println
end.

Примеры
Введите число: 12345.09876
Введите величину сдвига десятичной точки: -3
12.34509876

Введите число: 345.09876
Введите величину сдвига десятичной точки: 4
3450987.6

Введите число: 12345.09876
Введите величину сдвига десятичной точки: 8
1234509876000

Введите число: 12345.09876
Введите величину сдвига десятичной точки: 15
1.234509876E+19

Введите число: 1.23456789e-10
Введите величину сдвига десятичной точки: -25
1.23456789E-35
0,0(0 оценок)
Ответ:
nastyakarina112
08.10.2020 11:42
Var r,i:integer;
a:real;
begin
write('Введите число: ');
readln(a);
write('Введите число разрядов (позиций): ');
readln(r);
if(r>0) then for i:=1 to r do a:=a*10;
if(r<0) then for i:=1 to abs(r) do a:=a/10;
writeln(a)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота