HelloyKiss
03.08.2021 15:52

Составить блок-схему и написать программу для определения суммы нечетных цифр некоторого числа n. указание: для того, чтобы взять одну цифру из заданного числа n необходимо использовать операцию n mod 10.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kosmikanna
08.10.2020 05:41
Замечание: считается, что число N - натуральное.
Блок-схема - в прилагаемом файле.
var a,s:integer;
begin
readln(a);
s:=0;
while a>0 do
 begin
 if a mod 2=1 then s:=s+a mod 10;
 a:=a div 10;
 end;
writeln('s = ',s);
end.

Пример:
1234567
s = 16
Составить блок-схему и написать программу для определения суммы нечетных цифр некоторого числа n. ук
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота