DPAKOSHKA
07.05.2021 22:04

Составить программу которая в массиве а 12 находит среднее арифметическое

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
настя7589
08.10.2020 10:31
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(12,-50,50); a.Println;
  Writeln('Среднее арифметическое: ',a.Average)
end.

Пример
30 34 4 -13 35 2 31 -23 -30 44 4 -37
Среднее арифметическое: 6.75
0,0(0 оценок)
Ответ:
анна2265
08.10.2020 10:31
Var
a:array [1..12] of integer;
i,s:integer;
begin
for i:= 1 to 12 do
a[i]:= Random(10);
writeln(a);
for i:=1 to 12 do s:=s+a[i];
writeln('Среднее арифметическое всех элементов массива равно ',s/12:0:3)
end.

Пример:
[7,8,9,8,4,5,7,6,9,5,6,1]
Среднее арифметическое всех элементов массива равно 6.250
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота