Войти
Регистрация
Спроси ai-bota
Direct228
09.07.2022 22:15
Паскаль. дано натуральное число n, вещественные числа x1,, где n - кол-во чисел. найти среднее и наименьшее.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
СергейРовкин
29.08.2022 03:10
Си написать программу. Дан массив и в каждом элементе условно секунды a[0]=20 a[1]=21 a[2]=21 a[3]=35, с каждый следующий элемент либо больше на сколько то либо равен...
АннаПетух
29.11.2020 03:35
ПАРНИ ! С++ Обчислити вектор середньоарифметичних значень елементів рядків матриці дійсних чисел розміром 5x4....
6aPaLlJek
06.10.2020 22:39
Решить то, что слева) к 1 трем функциями \нужна схема и таблица истинностико второму таблица истинностиесли можно то с объяснением, или источник на объяснение, буду...
124taafo
03.06.2023 08:56
Хелп ми ! я немогу понять почему когда я тестирую программу на все ответы выскакивает то что в окне вывода на фото.хотя должно ещё отвечать другие ответы.!...
Маргоритка2009
29.05.2020 02:38
всем добрый день! метод симплекс мне нужно написать программу ,вычисляющую на языке с++ или же с# f = 10x1+12x2+14x3+11x4 при следующих ограничениях x1+x2+2x3+x4+x5=100...
notty12
13.07.2022 09:05
Для чего нужно линейка microsoft word дайте точнее ответ ...
Отлицница23
05.06.2020 11:29
Всистеме счисления с некоторым основанием n число 79 записывается в виде 211n найдите основание...
klimenkovlad598
25.11.2021 15:10
Паскаль. массив состоит из 20 положительных и отрицательных целых чисел выбранных случайно. выведите исходный массив. а затем в отдельных строчках положительные элементы...
motorindmitry12
28.01.2020 21:03
Что будет выведено на экран после выполнения программы #include #include int main() { int *p1,*p2; int q1,q2,q3; q1=2; q2=5; p1=& q1; p2=& q2; q3=*p1+*p2; printf(...
tania071168
05.08.2022 12:40
Что будет напечатано в результате работы программы #include #include int main() { int *p1,*p2; int q1,q2,q3; q1=2; q2=5; p1=& q1; p2=& q2; q3=*p1-*p2; printf(...
Ответ:
innahot418
08.10.2020 07:48
PascalABC.NET 3.3.5, сборка 1644 от 23.03.2018
Внимание! Если программа не работает, обновите версию!
begin
var a:=SeqRandom(ReadInteger('n='),-99,99).Select(t->0.1*t).ToArray;
a.Println;
Writeln('Среднее ',a.Average:0:4,', минимум ',a.Min)
end.
Пример
n= 15
2.8 -7.8 1.7 0.2 8.7 1.9 -6.3 -6.4 -0.2 5.4 -7.3 5.7 -8 -3.3 9.2
Среднее -0.2467, минимум -8
0,0
(0 оценок)
Ответ:
sasasnikas
08.10.2020 07:48
//PascalABC.NET
//Версия 3.3, сборка 1634 (14.02.2018)
begin
var x:=ArrRandomReal(ReadInteger('n->'),-100,100);
for var i:=0 to x.Length-1 do Write(x[i]:0:3,' '); Writeln;
Writeln('Среднее:',x.Average:0:3); Writeln('Минимальное:',x.Min:0:3);
end.
Пример:
n-> 10
2.753 -98.086 -26.848 55.284 -31.729 -72.603 -38.772 -12.801 53.627 -7.935
Среднее:-17.711
Минимальное:-98.086
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота