Маргоритка2009
29.05.2020 02:38

всем добрый день!
метод симплекс
мне нужно написать программу ,вычисляющую на языке с++ или же с#
f = 10x1+12x2+14x3+11x4
при следующих ограничениях
x1+x2+2x3+x4+x5=100
2x1+3x2+3x3+4x4+x6=180
3x1+3x2+2x3+4x4+x7=160
,

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
HGRM
22.10.2022 01:39

Для начала, переведем код в десятичную систему счисления.

110100102 = 21010

110011002 = 20410

110011112 = 20710

110100112 = 21110

Получаем: 210 204 207 211

Зная, что буква «А» кодируется как 192, а код каждой последующей буквы на 1 больше кода предыдущей буквы. Определим код остальных букв и расшифруем наше слово.

А-192

Б-193

В-194

Г-195

Д-196

Е-197

Ё-198

Ж-199

З-200

И-201

Й-202

К-203

Л-204

М-205

Н-206

О-207

П-208

Р-209

С-210

Т-211

У-212

Ф-213

Х-214

Ц-215

Ч-216

Ш-217

Щ-218

Ъ-219

Ы-220

Ь-221

Э-222

Ю-223

Я-224

СЛОТ

0,0(0 оценок)
Ответ:
Мурад1001
04.06.2022 19:11

Я вот тоже Вышел порешать =).

var p: array [1..1000] of record

slovo:string;

k:integer;

end;

N,i,j,max:integer;

c:char;

a:array [97..122] of integer;

BEGIN

max:=0;

readln(N);

for i:=1 to N do

begin

p[i].slovo:='';

repeat

read(c);

p[i].slovo:=p[i].slovo+c

until c=' ';

readln(p[i].k);

for j:=1 to length(p[i].slovo) do

if (ord(p[i].slovo[j])>=97) and (ord(p[i].slovo[j])<=122) then

a[ord(p[i].slovo[j])]:=a[ord(p[i].slovo[j])]+p[i].k;

end;

for j:=97 to 122 do

if a[j]>max then

max:=a[j];

write(max);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота