дзхен
02.11.2020 22:21

Написать программу вычисления а10, где а - данное число если получившаяся программа требует более четырех умножений (использование функции sqr тоже считается умножением), то дать более экономное решение.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sddnblck
08.10.2020 07:07
Var a,a2,a4,a8,a10:integer;
begin
readln(a);
a2:=a*a; // a^2
a4:=a2*a2; // a^4
a8:=a4*a4; // a^8
a10:=a8*a2; // a^10
writeln(a10);
end.

Пример:
2
1024
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота