Qwiq
25.03.2021 05:21

Напишите программу, которая заполняет массив из 16 элементов случайными числами на отрезке [-4; 4] находит произведение ненулевых элементов. 50 !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
slaadkoo
26.08.2020 23:38
Program fpro;

var
a : array[1..16] of integer;
i,p : integer;

begin
randomize;
p:=1;
for i :=1 to 16 do begin 
a[i] := random(-4,4); 
if (a[i] <> 0) then p:=p* a[i]; 
write(a[i]+' ');
end;
writeln();
write('Произведение = ', p);
end.
0,0(0 оценок)
Ответ:
софа336
26.08.2020 23:38
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(16,-4,4); a.Println;
  a.Where(t->t<>0).Aggregate(1,(i,j)->i*j).Println
end.

Пример
-2 -1 1 -3 -2 2 0 -4 0 2 4 -2 -4 4 3 -1
73728
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота