nini8523
19.01.2022 16:42

Составить программу: дан массив из n элементов, посчитать произведение положительных элементов ..

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
katyauauauaua
08.10.2020 01:48
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  Writeln('Произведение положительных элементов равно ',
      a.Where(x->x>0).Aggregate(BigInteger(1),(p,q)->p*q))
end.

Составить программу: дан массив из n элементов, посчитать произведение положительных элементов ..
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота