Vladik451051
22.02.2020 17:45

1. написать программу, которая подсчитывает количество, сумму и среднее арифметическое положительных чисел последовательности. размер последовательности определяет сам пользователь программы. 2. написать программу, которая подсчитывает сумму и количество чисел последовательности, делящихся на 8 без остатка. размер последовательности определяет сам пользователь программы. принять, что последовательность состоит только из целых положительных чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ExDragon
07.10.2020 23:44
Varsumma,Shet,a,b,c:integer;SAP:real;L:array [1..999] of integer;beginWrite('Сколько чисел? ');read(a);for b:=1 to a do beginwrite('Введите число ' );read(c);if (c>0) then begin Shet:=Shet+1; summa:=summa+c; SAP:=SAP+c; end;end;SAP:=SAP/Shet;Writeln(' Сумма = ',summa,' Сред = ',SAP:5:5,' Количество = ',Shet);read(a);end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота