mdotsenko
01.07.2021 00:57

Легко но меня не было на уроке написать программу: с клавиатуры вводиться число n. заполнить массив n случайными числами. в массиве может находиться не более 100 элементов. упорядочить массив по возрастанию и сформировать новый массив, каждый элемент которого равен исходному плюс полученному элементу.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
myka1
07.10.2020 23:39
Program massiv;
var M: array [1..100] of integer;
M2: array [1..100] of integer;
a,n,i,i2 : integer;
begin
read (n);
for i:= 1 to n do begin
readln (a);
M[i]:=a;
M2[i]:=a;
end;
for i:= 1 to n do begin
for i2:= i+1 to n do begin
if (M[i]< M[i2]) then begin
a:=M[i2];
M[i2]:=M[i];
M[i]:=a;
end;end;end;
for i:=1 to n do begin
M[i]:= M[i]+M2[i];  
writeln(M[i]);
end;end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота