babywka56
04.09.2021 11:33

Составьте программу для вычисления суммы цифр заданного трехзначного числа. на паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tatu261
10.08.2020 21:29
Var
  n:integer;
 
begin
  Write('n = '); Read(n);
  Writeln(n div 100+(n div 10) mod 10+n mod 10)
end.

Пояснения.
n div 100 дает первую цифру: результат деления нацело числа на 100.
(n div 10) mod 10 дает вторую цифру: вычисляется результат деления нацело числа на 10 и от него берется остаток деления на 10.
n mod 10 дает третью цифру: остаток целочисленного деления числа на 10.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота