Katyaguccigang
18.05.2022 18:08

Максимум .
нужно составить программу на паскале (ниже само ).

если хотя бы два числа из трех введенных чисел положительны, то
уменьшить каждое нечетное число на 1, иначе – найти сумму всех
чисел.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nikpenkov02
07.10.2020 20:34

var a,b,c,kol:integer;

 begin

   readln(a,b,c);

if a>0 then inc(kol);

if b>0 then inc(kol);

if c>0 then inc(kol);

if kol>=2 then

                      begin

                        if a mod 2=1 then dec(a);

                        if b mod 2=1 then dec(b);

                        if c mod 2=1 then dec(c);

                      end

  else writeln(a+b+c);

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота