borovitskii2014
27.01.2022 07:48

Написать программу на языке си программа должна выполнять команду заменить наименьшее из трёх чисел x, y, z нулем и напечатать все три числа ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
АннаМарияЛуиза
20.02.2022 18:43
Var
   A:array[1..100,1..100] of integer;
   i,j,N,z:integer;
Begin
WriteLn('Введите размерность матрицы A[N,N]:');
Write('N = ');
ReadLn(N);
WriteLn('Как заполнить матрицу?');
WriteLn('1 - автоматически, 0 - с клавиатуры');
ReadLn(z);
if z=1 then
   For i:= 1 to N do
       Begin
       For j:= 1 to N do
           Begin
           A[i,j]:=random(21)-10;
           Write(A[i,j]:3,' ');
           End;
       WriteLn
       End
else
   For i:= 1 to N do
       For j:= 1 to N do
           Read(A[i,j]);
z:=1;
For i:= 1 to N do
    For j:= 1 to N do
        if A[i,j]<>A[j,i] then z:=0;
if z=1 then WriteLn('Матрица семметрична относительно главной диагонали')
else WriteLn('Матрица не семметрична относительно главной диагонали')
End.
0,0(0 оценок)
Ответ:
soullina
07.06.2023 03:42
1)
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
begin
    var a := ArrRandomInteger(20, 100, 200);
    Println(a);
    var k := a.Count(x -> x mod 10 = 5);
    Writeln((k = 0) ? 'Таких чисел нет' : k.ToString());
end.

2)
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
begin
    var a := ArrRandomInteger(40, -100, 100);
    Println(a);
    var max := a.Count(x -> x mod 3 = 0);
    if max <> 0 then
        max := a.Where(x -> x mod 3 = 0).Max;
    Writeln((max = 0) ? 'Таких чисел нет' : max.ToString());
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота