Shved11
08.04.2020 01:38

Написать программу, которая заполняет массив из 30 чисел и подсчитывает разность между минимальным и максимальным элементом

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
krepkinapolina29
07.10.2020 19:49
1. Современное решение

// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(30,-50,50); a.Println;
  Writeln('Разность между минимальным и максимальным элементом ',
      a.Max-a.Min)
end.

Пример
-31 41 -37 18 -44 -34 -13 7 30 -22 -33 47 -1 -4 -17 -21 32 -3 24 -15 43 -41 44 36 5 2 -47 -39 5 -13
Разность между минимальным и максимальным элементом 94

2. Так обычно (не не всегда!) учат в школе

program SelenaMarogom;

const
  n=30;
 
var
  i,min,max:integer;
  a:array[1..n] of integer;
 
begin
  Randomize;
  min:=100; max:=-100;
  for i:=1 to n do begin
    a[i]:=Random(101)-50;
    Write(a[i],' ');
    if a[i]>max then max:=a[i];
    if a[i]<min then min:=a[i]
    end;
  Writeln;
  Writeln('Разность между минимальным и максимальным элементом ',max-min)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота