oksana1111156970
05.08.2020 20:13

Напишите программу, при выполнении которой с клавиатуры считывается натуральное число N, и выводится сумма цифр этого числа.
Язык программирования — Python

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nikabagirovap0dq1g
04.11.2021 17:20

Программа:

Python:

Вариант 1)

N = int(input())

sum = 0

while N > 0:

   j = N % 10

   N //= 10

   sum += j

print(sum)

Вариант 2)

print(sum([int(j) for j in input()]))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота