Войти
Регистрация
Спроси ai-bota
YeGoR17
24.08.2022 05:47
Pascal .заменить 1-й элемент одномерного массива на среднее значение его элементов.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ильир
05.04.2021 16:29
Напишите для робота алгоритм, закрашивающий все клетки, расположенные с внутренней стороны правой и нижней стен. робот должен закрасить только клетки, удовлетворяющие данному...
IdaPosion
05.04.2021 16:29
Нужно сделать какой-нибудь проект в movie maker не подкините идей? что вообще можно сделать?...
laralarisa
05.04.2021 16:29
Информационное сообщение на языке, первоначально записанное в 8- битовом коде кои- 8,было перекодировано в 16-битовую кодировку unicode. в результате его объем увеличился...
Кейси001
22.02.2023 23:36
1.фото пример 2.фото задачи...
vlad499999
30.06.2020 20:17
Двоичное кодирование, конспект...
mmila4764
12.03.2020 02:03
определи истинность утверждения. Беспроводные сети при работе мешают друг другу. В местах где одновременно работает несколько сетей на одинаковом или близком канале передачи,...
Онелик
22.03.2020 16:52
Для чтения файла используется метод какой?...
morozmoroz12
05.09.2021 07:43
Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел. число n вводится с клавиатуры . выполнить программу для n=13...
nargiz999
21.07.2020 10:35
Как называется устройство, предназначенное для оцифровки изображений? ...
dimapudov2007
02.08.2020 07:21
очень нужно. НУЖНО НАПИСАТЬ ПРОГРАММУ В Python массив нужно вводить самим с клавиатурыэто нужно вставить в конецlist.append(x)добавление элемента х в конец списка list...
Ответ:
катейка22
21.08.2020 08:56
//PascalABC.NET 3.3,сборка 1611 от 06.01.2018
//Внимание! Если программа не работает, обновите версию!
begin
var a:=1.0;
var n:=readinteger('n=');
var mas:=ArrRandomReal(n,-99,99);
var h:=mas.Select(t->round(t*100) /100).ToArray; h.Println;
for var i:=0 to n-1 do
a:=a*h[i];
a:=a*(1/n);
h[0]:=a;
writeln('среднее неометрическое =',a);
h.println;
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота