Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел. число n вводится с клавиатуры . выполнить программу для n=13 , записать результат
Const n=13; var i,s,p:integer; begin s:=0; p:=1; for i:=1 to n do begin if (i mod 2 = 0) then s:=s+i; if (i mod 2 <> 0) then p:=p*i; end; writeln("Сумма четных = ",s," , произведение нечетных =",p); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку