Войти
Регистрация
Спроси ai-bota
nikolay2045
18.04.2021 14:36
Программа на pascalabc.net + блок схема заполнить двумерный массив случайным образом и найти произведение больших 5 и кратных 3
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
nazarovradion
27.11.2021 09:12
Вклассе 12 детей, причем мальчиков в 3 раза больше, чем девочек. сколько девочек и мальчиков в классе?...
dadamuhamedovag
27.11.2021 09:12
Написать алгоритм: даны 2 числа a и b оба вводятся с клавиатуры , написать алгоритм нахождения наибольшего из них...
W1LDOR
29.04.2021 13:26
Напишите программу, вычисляющую значение функции Y: если a b 0 При этом у пользователя должны запрашиваться ввод значений переменных A и B с клавиатуры, т.е. при запуске программы...
SizovMarina
16.03.2021 23:02
Книга содержит 122 страниц. На каждой странице 39 строк. В каждой строке 57 символов (включая пробелы). Найти информационный объём текста, считая, что каждый символ кодируется одним...
V5Ch
21.09.2022 08:02
Найдите, в каких строках правильно записан условный оператор.1) if (A 0) B := A + 5; else B = A – 5; 2) if (A 0) B = A + 5 else B = A – 5; 3) if (A 0) B = A + 5; else B = A – 5; 4)...
alyamiller1513
04.03.2020 20:53
Что будет напечатано в результате выполнения следующих программ (and обозначает логическое И , or - логическое ИЛИ )...
777Leha777
16.01.2022 14:06
Что идет из города в город, но при этом недвижется?...
Irynadv
12.04.2020 00:40
Составте программу: среди двузначных чисел найти кол-во чисел которые неоканчиваются на ноль и кратных трём , с объяснением !...
dianaTe
12.04.2020 00:40
Склавиатуры вводятся два натуральных числа a, b (a =b). найти в диапазоне от a до b (включая границы) число, имеющее максимальную сумму делителей. (pascal) с применением функции...
lazzat8
12.04.2020 00:40
Укого,-нибудь есть загадки про exсel? там про рядки, столбики, таблица, странница, листок и т.д....
Ответ:
Arukaa2087
07.10.2020 16:43
//PascalABC.NET 3.3,сборка 1611 от 06.01.2018
//Внимание! Если программа не работает, обновите версию!
begin
var mas:=MatrRandom(5,5,-99,99); mas.Println;
var b:=mas.ElementsByCol.Where(t->(t>5) and (t mod 3 =0));
var c:=b.Aggregate(biginteger(1),(x,y)->x*y);
Writeln('Произведение =',c)
end.
Как в школе учат :
const n=5; m=5;
var
a,b,c,i,j:integer;
mas:Array [1..n,1..m] of integer;
begin
randomize;
for i:=1 to n do
for j:=1 to m do
mas[i,j]:=random(100);
c:=1;
for i:=1 to n do
for j:=1 to m do
if (mas[i,j]>5) and (mas[i,j] mod 3 =0 ) then
c:=c*mas[i,j];
Writeln('Произведение =',c);
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота