W1LDOR
29.04.2021 13:26

Напишите программу, вычисляющую значение функции Y: если a>b>0
При этом у пользователя должны запрашиваться ввод значений переменных A и B с клавиатуры, т.е. при запуске программы на экран должно быть выдано сообщение «Введите значение переменной A» и пользователь вводит его, затем на экран выдается сообщение «Введите значение переменной B» и пользователь вводит его. Далее в зависимости от условий будет вычислен Y по первой или второй формуле.
Вывести на экран получившееся значение Y.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alisavakhnina1
16.10.2021 23:57
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-99,99); a.Println;
  a.OrderBy(t->t).Println; // 1
  var b:=Copy(a); b.Transform(t->t mod 10=0?0:t); b.Println; // 2
  Range(2,n-1,3).Select(i->a[i]).Println; // 3
  Writeln('Элементов после max: ',n-a.IndexMax-1) // 4
end.

Пример
n= 20
8 37 88 31 -15 -26 -34 24 -31 -31 -91 -40 -49 -91 45 -30 -79 -78 -2 39
-91 -91 -79 -78 -49 -40 -34 -31 -31 -30 -26 -15 -2 8 24 31 37 39 45 88
8 37 88 31 -15 -26 -34 24 -31 -31 -91 0 -49 -91 45 0 -79 -78 -2 39
88 -26 -31 -40 45 -78
Элементов после max: 17
0,0(0 оценок)
Ответ:
teodormax
26.10.2022 12:54
Для начала стоит разобраться в том, насколько программирование востребовано в современном мире. Программист - это человек, который не только хорошо разбирается в компьютерах, но и создает новые программы, а также сайты. Фактически это сотрудник, занимающийся IT-технологиями. Программирование - перспективное направление. Получив диплом по соответствующей специальности, можно построить хорошую карьеру. Заработок программиста в среднем составляет 100-150 тысяч рублей. Именно поэтому многие задумываются над поступлением. - 
В список подобных вступительных испытаний входит всего 2 предмета. А именно: русский язык; математика. -
прочее-физика; информатика; иностранный язык
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота