dawlatowaalbina
17.11.2021 17:43

Составьте программу вычисления суммы отрицательных элементов в массиве a[1..10]. + сделать чтобы это с .txt файла вводилось. я не знаю как, но тема "работа с текстовыми файлами".

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Алекс2521
07.10.2020 12:32
Var i,k,s: integer;
    f: text;
begin
  assign(f,'c.txt');
  reset(f);
  s:=0;
  for i:=1 to 10 do
  begin
    read(f,k);
    write(k,' ');
    if k<0 then s:=s+k;
  end;
  close(f);
  writeln;
  writeln('сумма отрицательных: ',s);
end.

Файл c.txt во вложении.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота