karinabuchneva16
16.02.2022 11:02

Напишите программу в которой определяется сумма s всех целых чисел в интервале заданном переменами n и m а так же сумма sa четных и sb нечетных в этомже интервале

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
krasnuykkisa
07.10.2020 08:33
Язык С#
код:
using System;namespace ConsoleApp95{    class Program    {        static void Main(string[] args)        {            int N, M,S = 0 ,SB = 0 ,SA = 0 ;            N = Convert.ToInt32(Console.ReadLine());            M = Convert.ToInt32(Console.ReadLine());            for ( int i = N+1; i < M; i++)            {                if ( i % 2 == 0 )                {                    S += i;                    SA += i;                }                else                {                    SB += i;                }            }            Console.WriteLine(S + "   " + SA + "  " + SB);            Console.ReadKey();        }    }}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота