veronikamantul
14.06.2020 14:09

, составить программу в Scratch Дано целое число N (> 1). Вывести наибольшее из целых чисел K, для которых сумма 1 + 2 + … + K будет меньше или равна N, и саму эту сумму.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
juliadzyombak
28.09.2021 23:35

#include <iostream>

#include <cmath>

using namespace std;

int main() {

 int B[16]; // создаём пустой массив

 srand(time(NULL)); // делаем так что бы функция rand() зависла от времени и не была постоянной

 for(int i = 0; i < 16; i++) { // заполняем массив случайными числами

   B[i] = rand() % 100;

 }

 for(int i = 0; i < 16; i++) { // выводим массив

   cout << B[i] << ", ";

 }

 cout << endl;

 int tmp = B[1]; // создаём временну переменную для хранения значения 2 элемента массива

 B[1] = B[14]; // присваиваем 2 элементу значение предпоследенго

 B[14] = tmp; // присваиваем предпоследенему элементу значение временной переменной

 for(int i = 0; i < 16; i++) { // выводим массив

   cout << B[i] << ", ";

 }

 cout << endl;

}

Объяснение:

0,0(0 оценок)
Ответ:
Hollaholla322
25.11.2022 23:27
о том лылвдаоврч. малая лздп т в том числе и в итоге я не знаю что делать будешь сегодня в школе не было бы круто если бы я была на концерте была бы не сказала бы сразу и не надо от него и так все плохо было не до конца жизни был назначен на должность начальника штаба дивизии и в итоге я не знаю почему так долго не могла бы и г в состав округа уже не будет на месте и не знаю как г г г И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота