234432343342
03.03.2021 03:28

Составить программу в паскале 10 абитуриентов сдали экзамены (максимальная сумма за три экзамена 300). посчитать проходной , если известно, что он составляет 80% от среднего . посчитать количество зачисленных и вывести номера зачисленных абитуриентов.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ГЕОГАФИЯ
10.08.2020 18:25
Const n=10; m=3;
var 
a:array[1..n,1..m] of integer;
i,j,s,k:integer; p:real;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
   a[i,j]:=random(81)+20;
   write(a[i,j]:4);
  end;
  writeln;
 end;
s:=0;
for i:=1 to n do
 for j:=1 to m do s:=s+a[i,j];
p:=s/n*0.8;
writeln('p = ',p:5:2);
writeln('Зачислены:');
k:=0;
for i:=1 to n do
 begin
 s:=0;
 for j:=1 to m do s:=s+a[i,j];
 if s>=p then begin write(i,' '); k:=k+1; end;
 end;
writeln;
writeln('k = ',k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота