Волна1610
22.02.2022 22:34

Составить программу в pascal, которая в тексте после каждой буквы вставляет заданный символ (с стандартных процедур)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mansursatuev
07.10.2020 08:11
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите текст:');
  var c:=ReadlnChar('Введите букву для вставки');
  var s1:='';
  for var i:=1 to s.Length do begin
    s1+=s[i];
    if s[i]<>' 'then s1+=c
    end;
  Writeln(s1)
end.

Пример
Введите текст: Привет паскалю!
Введите букву для вставки Ы
ПЫрЫиЫвЫеЫтЫ пЫаЫсЫкЫаЫлЫюЫ!Ы
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота