viktoriyabochko
09.05.2023 10:12

Составьте программу в pascal abc, которая заполняет массив а(1..10) случайными целыми числами в диапазоне от 1 до 100 , затем меняет местами максимальный и минимальный элементы. выведите на экран исходный и полученый массивы

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Селена24на7
07.10.2020 07:32
Var
  a: array[1..10] of integer;
  i, max, imax, min, imin: integer;

begin
  Randomize;
  max := 0;min := 101;
  Write('Исходный массив:        ');
  for i := 1 to 10 do
  begin
    a[i] := random(100) + 1;
    Write(a[i], ' ');
  end;
  Writeln();
  For i:= 1 to 10 do begin
   if a[i] > max then
    begin
      max := a[i];
      imax := i;
    end;
    if a[i] < min then
    begin
      min := a[i];
      imin := i;
    end;
  end;
  swap(a[imax], a[imin]);
   Write('Преобразованный массив: ');
   For i:= 1 to 10 do
     Write(a[i], ' ');
   Writeln;
   Write('Я поменял местами ', imax, ' и ', imin, ' элементы');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота