Войти
Регистрация
Спроси ai-bota
frogRICH
30.10.2022 01:19
Написать программу в pascal, которая сортирует массив и находит количество различных чисел в нём
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
dflbvdflbv
04.01.2021 11:33
Определи причину необходимости использования заполнителя в перечне выбранных графических объектов. для заполнения пустого пространства в строке для определения номера указанного...
Роксолана123456789
10.01.2020 09:27
Подготовка к промежуточной аттестации по информатике...
JLemast
29.01.2022 10:36
Даны три числа. выберите те из них которые принадлежат заданному отрезку [e, f]. !...
amina24569
15.09.2021 03:10
Одномерные массивы, удовлетворяющие условию: дан массив а целых произвольных чисел, лежащих в диапазоне от -15 до 15. длина массива задается произвольно, но их меньше 100. найти...
Лолыч11
20.01.2020 06:31
Решить по информатике, составить к ним блок схему и программу. 1. результаты 20 измерений некоторой величины заданы таблицей. определить среднее арифметическое результатов и отклонение...
Маркіза1
30.05.2021 05:28
Что не относится к технике линейка, пенал, весы, компьютер...
Катерина26121
17.04.2021 06:19
Напишите программу на языке программирования C ++, которая будет реализовывать следующие действия: 1. Требовать ввести 2 целых числа. С цикла отобразите числа от первого введенного...
vkunney
12.05.2022 06:47
Які властивості має команда в середовищі scratch...
таня2027
21.02.2020 02:10
Напишите программу обмена сомов на доллары и евро в Python...
vvbybrjnbr
20.12.2022 20:11
Подчеркни на рисунке инструмент для прикрепления файла. в) Напиши название папки, в которой Алуа найдет это письмо...
Ответ:
Touka1337
07.10.2020 07:20
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
a.Sort; a.Println;
Writeln('Кол-во разных чисел равно ',a.Distinct.Count)
end.
Пример
n= 13
-1 1 3 -2 8 -9 9 -1 -8 -8 9 -9 2
-9 -9 -8 -8 -2 -1 -1 1 2 3 8 9 9
Кол-во разных чисел равно 9
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота