amina24569
15.09.2021 03:10

Одномерные массивы, удовлетворяющие условию: дан массив а целых произвольных чисел, лежащих в диапазоне от -15 до 15. длина массива задается произвольно, но их меньше 100. найти количество элементов, кратных заданному f. вывести исходный массив. написать программу в бейсике

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
99669888Nina
01.06.2023 22:59

Для того чтобы работать с текстами на персональном компьютере или ноутбуке обычно используют специальные программные средства, которые принято называть текстовыми редакторами. Стоит отметить, что на сегодняшний день существует довольно большое разнообразие подобных программ, которые различаются своими возможностями и функциями, но наиболее популярным (по числу использования пользователями) остается MS Word 2010.

Вообще, основным назначением текстовых редакторов является создание текстовых файлов, редактирование уже готовых (или недоделанных) текстов с возможностью их на экране, изменять их формат, а также распечатывать на принтере. Кстати, следует уточнить, что Блокнот и другие аналогичные редакторы предназначены только для обработки несложных текстовых файлов, но никак не для работы с большим текстом.

Самым большим по своим возможностями до сих пор считается MS Word — текстовый редактор от компании Microsoft. В нем так же, как и во многих его аналогах можно:

форматировать символы, абзацы;

оформлять страницы;

"строить" указатели и оглавления;

включать в тесты графические объекты: фотографии, диаграммы, рисунки;

создавать таблицы, проверять правописание и т. д.

В современном мире существует уже много версий MS Word, наиболее популярными среди них считаются версии 2003, 2007, 2010 и 2013 года выпуска. Современный текстовый процессор Microsoft Word предназначен для создания, печати и модификации текстовых документов. Он предусматривает выполнение многих операций, как над текстовой, так и над графической или табличной информацией. Благодаря MS Word стало возможно быстро, а также с высоким качеством подготовить любой документ, причем от сложного до дает возможность осуществлять все традиционные операции над текстом (без исключений), которые предусмотрены в компьютерной современной технологии. С его можно:

модифицировать набор неформатированной цифровой и алфавитной информации;

форматировать символы, применяя множество шрифтов разных размеров и начертаний;

форматировать страницы (сюда также входят сноски, колонтитулы);

форматировать документ в целом (составлять оглавление, причем автоматическое, а также разные указатели);

подбирать синонимы, проверять правописание, использовать автоматический перенос слов.

В этой программе реализованы возможности новых технологий связывания, внедрения объектов, благодаря которым можно в документ включать таблицы, текстовые фрагменты и иллюстрации.

Это одна из первых общедоступных программ, с которой можно выполнять операции верстки, которые порой необходимы издательским профессиональным системам, а также с ее можно подготавливать полноценные оригинал-макеты для их последующего тиражирования в типографии.

Данная программа является уникальной коллекцией технологических оригинальных решений, благодаря которым нудная и кропотливая работа по отделке и редактированию текста превращается в увлекательное, а порой и успокаивающее занятие. В число таких решений входит система готовых стилей оформления и решений, изящные приемы по модификации и созданию таблиц, функции автозамены и автотекста, а также копирование формата, макроязык, пользовательские панели инструментов и многое другое.

Многие привыкли к другим же нравится оригинальный интерфейс версий 2007 или 2010 года выпуска. В основном же это дело привычки. Самое главное, что в современном мире это самый удобный, интуитивно-понятный и полезный инструмент для работы с текстовыми файлами

0,0(0 оценок)
Ответ:
Soniadesor
21.11.2020 06:35

a = int(input())

for i in range(a):

 b = input()

 c = 0

 d = True

 e = 0

 f = False

 g = False

 h = '\''

 for j in b:

   if j == '#' and not f:

     g = True

     break

   elif j != ' ':

     if d:

       print(' ' * c, end='')

     elif c > 0:

       print(' ', end='')

     c = 0

     print(j, end='')

     if(j == '\"' or j == '\'') and e % 2 == 0:

       if f and j == h:

         f = False

       else:

         f = True

         h = j

     if f:

       d = True

     else:

       d = False

     if j == '\\':

       e += 1

     else:

       e = 0

   else:

     c += 1

   r = j == ' '

if g and c > 1:

 print(' ', end='')

if i < a - 1:

 print()

1

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота