sofya15081987
01.06.2020 12:28

Напишите программу, которая шифрует тексты следующим образом: исходная строка разбивается на части по 4 символа и эти четыре символа перемещаются по кругу влево на одну позицию. если последняя группа символов состоит из 1, 2 или 3 символов, то они остаются неизменными.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
гость162
07.10.2020 03:57
#include <iostream>
#include <string>
using namespace std;
int main(){
setlocale(LC_ALL, "Russian");
cout << "Введите строку: ";
string line; cin >> line;
for(int i = 0; i < line.length()/4; ++i){
char buff = line[4*i];
line[4*i]=line[4*i+1];
line[4*i+1]=line[4*i+2];
line[4*i+2]=line[4*i+3];
line[4*i+3]=buff;
}
cout << "ответ: " << line << endl;
system("pause");
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота