кратос2315
29.12.2020 11:31

Написать программу в с++ натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая это самое число. например, число 6 является совершенным (1+2+3 = 6). найти все совершенные числа, меньшие 100 000.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zombi17
07.10.2020 03:11
#include <iostream>
using namespace std;

int main(){
    int s;
    for (int i=2; i<=100000; i++){
    s = 1;
    for (int j=2; j<=i/2; j++)
    if (i % j == 0) s+=j;
    if (s == i)
    cout << i << " ";
    }
    return 0;
}

Результат:
6 28 496 8128
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота