Войти
Регистрация
Спроси ai-bota
alina151103
02.02.2022 22:03
Надо сдать! написать программу на языке с++ дана последовательность n различных целых чисел. найти сумму ее членов,расположенных между максимальным и минимальным значениями(в сумму включить и оба этих числа).
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
raha12003
03.08.2020 08:51
Информатика хелп(()()()((()())...
shepa174
25.11.2022 11:35
Составьте программу ,которая запрашивает название футбольного клуба и повторяет его на экране с - чемпион!...
ВКВКВКВКВКВКВК
06.10.2020 05:15
9 класс, у логическое выражение...
AcidSmile
17.07.2020 03:38
Дано трехзначное число. Верно ли, что все его цифры одинаковые?программа питон...
SamaraArtem24
23.10.2022 19:01
60 900*90-648*408+383 384-84*23= по действиям решите : ) как можно быстрее....
SeyshellaGoa
23.10.2022 19:01
Зная что купили 8 наборов кнопок по цене 12 руб шт во сколько раз должна уменьшится цена набора кнопок чтобы за ту же стоимость можно было купить 16 таких же наборов...
cheropitan
23.10.2022 19:01
правильно составить предложение из этих слов по казахскому! буду . аралас сөздерден сөйлем құраңыз. 1.тұрған / түркістанда / біздің / ата-. 2.ойларың /сендердің /дұрыс....
VladimerGen
23.10.2022 19:01
4. 1) найди периметр четырехугольника, стороны которого равны 8 см, 5 см, 7 см, 6 см. 2) запиши длины сторон двух других четырехугольников с таким же периметром....
invisiblefibers
23.10.2022 19:01
Как называется космодром в казахстане? какое стихотворение музафара алимбаева ты знаешь? как называется высокогорный каток в алматы?...
Dianissimolps
23.10.2022 19:01
Представителями листостебельных мхов является: 1сфагнум 2.маршанция 3.кукушкин лен 4.риччия водная...
Ответ:
hjhthy
07.10.2020 03:11
#include <iostream>
using namespace std;
int main()
{
int n,max, min, pos1, pos2, mem, sum;
cin >> n;
pos1 = 0;
pos2 = 0;
int *A = new int[n];
for (int i = 0; i < n; i++)
{
cin >> A[i];
}
min = A[0];
max = A[0];
for (int i = 0; i < n; i++)
{
if (A[i] > max)
{
max = A[i];
pos1 = i;
}
if (A[i] < min)
{
min = A[i];
pos2 = i;
}
}
if (pos2 > pos1)
{
mem = pos2;
pos2 = pos1;
pos1 = mem;
}
sum = 0;
for (pos2; pos2 <= pos1; pos2++)
{
sum = sum + A[pos2];
}
cout << sum;
system("pause");
return 0;
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота